Nye VGD er lansert! Mer informasjon

Hei!

Har en Kolonne i Excel (A1 til A10) Denne inneholder datoer. alle cellene i kolonnen er formatert slik at ved å skrive inn eks. "3.11" så blir det automatisk vist "Torsdag 3. November"

Jeg ønsker at celle B1 skal summere antall Torsdager i kolonnen... Hvordan gjøres dette?

Jeg prøvde med "=antall.hvis(a1:a10;"Torsdag*") men den returnerer "0"

Noen tips?

1
7 svar

7 svar

Logg inn med Schibsted

Du må være innlogget for å svare på dette innlegget!

Gå til innlogging

Aelous

=SUMMERPRODUKT(--(UKEDAG(A1:A10)=5))

Hvor 1 er Søndag, ... , 5 er torsdag osv.

1

FlGARO

Problemet med at tomme celler gir lørdag kan fikses slik:

=HVIS(A1;"";"";TEKST(A1;"dddd"))

Den sjekker altså først om A1 er tom, hvis den er tom, lar den også utregning bli tom. Er den ikke tom, så regner den ut dagen.

PS: Editoren klarte å fjerne et av "" ved redigering, men nå skal den være riktig.

1

Wigarth

=HVIS(A1;"";"";TEKST(A1;"dddd"))

Da får jeg melding om at jeg har angitt for mange argumenter.... prøvd å variere litt på det du beskriver, men jeg fikk det ikke til

Excel 2010 forresten

1

FlGARO

Det var rart. Som du ser så fungerer det ypperlig hos meg, celle D10 er tom, ergo lar den E10 være tom. D9 står det derimot noe, slik at den regner ut i E9.

http://bildr.no/view/T2ZNdHVM

Jeg sitter på Excel 2013, så det ville ikke overraske meg om at de atter en gang har endret på ting.

2

FlGARO

Beklager, editoren til VGD er faen meg føkka. Den endret = til ; av en eller annen grunn. Sjekk bildelinken jeg ga deg, den er i hvert fall 100 prosent riktig, uansett hva VGD sin editor mener om saken ;)

2

Wigarth

Jeg får til og bruke en ekstern celle som kan lese av dagen og returnere tekst

=tekst(a1;DDDD) den fungerer men nytt problem oppstår når den "tolker" alle tomme datoceller som "lørdag" Da blir det fort komplisert igjen

Har snart ikke hår igjen på hodet! ;-)

1

Lignende temaer

Bilde

Foto og video

Foto og video

Bilde

Vitenskap

Vitenskap

Bilde

Spill

Spill

Bilde

Data og Internett

Data og Internett

Bilde

Været

Været

Laster...